Slime Tube Adventuring Script

wojuff

New member
okay managed to get this to happen but it just stopped there.

> call scripts\relay_slime.ash

Sending kmail to Alhifar...
Installing default certificate validation...
Sending login request...
Synchronizing moon data...
You have the latest use_for_items.txt. Will not check again today.
Checking for updates (running ZLib rev. 35)...
Requests complete.
 

Theraze

Active member
That's not how you'd run a relay script. A relay script is run through the relay browser. Top-right corner, choose the slime from the dropdown list. Regarding non-relay scripts, you can call those.
 

lostcalpolydude

Developer
Do you have two separate mafia folders, and you're running from the wrong one?

Having relay_slime.ash in the scripts folder is going to be wrong, even if you also have it in the relay folder. Maybe the problem the whole time has been that you have it in the scripts folder?
 

Theraze

Active member
Theraze if you read my posts on the previous page it does not show up there hence my issue.

And I'm saying that trying to run a relay script from the gCLI will not work. So don't try to do that. In fact, having multiple copies of the same script scattered in your mafia folder tree may cause all copies to fail to run.
As lost said.

If manually going to the right address doesn't work, clean your mafia first - remove all of your scattered copies of relay_slime and, y'know, anything else that might be related. And then if it still doesn't work, try a completely clean mafia.

The script works. Your installation doesn't, and isn't a problem with relay_slime.
 

wojuff

New member
I never said the script did not work, I said it was not working for me, and I only have one copy. it works directly but does not show on the relay, so thank you for getting it to work for me, I feel like such a noob.
 

Voodooknigh

New member
Hey guys,

My script doesn't seem to want to work for more than 5 turns. Whenever I try to run the script, it goes as so:

Putting on outfit: Min ML
Equipment changed.
Resetting mind control device...
Mind control device reset.

Autorecovery failed.

How do I fix this? Thanks!
 

dab

New member
Not sure if I should start a new script, or i this is okay, but I had some trouble using the script here, so I just played the Tube manually for awhile. Once I was more comfortable with The Tube in general (knew what I could handle, when I needed to swap stuff out, etc.), I ended up making my own very simple script.

DISCLAIMER:
I don't really know what I'm doing with scripting. If it doesn't work for you, it's not super likely I will be able to help.
This is very much not optimal. It does not manage free runaways (though maybe your CCS could while using this). It does not manage buff or consumables. If I care about speed, I will go manually, not with this script.


View attachment dabslime.ash

It uses outfits "minml" and "maxml2" (because my maxml outfit is for speed runs, and requires more consumable management).
You can change these easily in the script. There aren't a lot of lines to sift through to find them.

It also assumes you want to use chamoix for cleaning yourself, and doesn't try for a hot tub.

So, all this one does is:
-Grab a cham (won't be used if you aren't already coated)
-Equip you minml outfit
-Spend 1 turn (does not try to free runaway, just kills the low lvl slime)
-Switch to maxml2
-Burns turns down to 4 turns of coated in slime.
-Asks you if you want to do it again.

So, it's only automated for 1 instance of Coated in Slime, and will require you to tell it you want to go again.

You can change how many turns of coated you can handle.
it shows up on line 19:

adventure(coat - 4, $location[The Slime Tube]);

Just change to 4 to whatever number you want to stop at.

If I knew how to ask the user how many turns, I could make that easier.
I guess I could also figure out how to use that to say how many times to repeat, too.


Anyway, hope this helps. If I should have put this in another thread, lmk. I don't use the forum much ...
 

djve

New member
I have a different mafia newbie questions.
And getting the answers in one post as they are spread out all over this topic.

1. I'm thought I was running minimal ML but the script keeps casting Aria of Annoyance. It also keeps turning on the radio to 10. So I'm running max ML. How do I get this to run min ML instead?
A (partial): Min and max is based on the custom outfit name with defaults of "minml" and "maxml". (still need to stop going to MaxML on round 2).

2. I can't see how to run this from the GUI. http://127.0.0.1:60080/relay_slime.ash works but I would like to invoke this from inside the GUI and not have to bookmark the URL.
A: In the relay browser - not the GUI, look at the top right for the "-run script-" dropdown.

3. The latest version is missing the version number from the page. Is this going to be restored?

4. Is there a way to call this from the graphical CLI panel? I've tried "call slime 3", "slime 3", and "call relay_slime 3" but nothing worked.
 
Last edited:

taltamir

Member
I made an update. 2019-07-04 update:
Added clan functionality. Can just leave blank, in which case everything will be done in current clan.
Can auto switch clans to slimetubing clan, hottub clan, and chamois bucket clan.
Tested (with big bundle of chamois costing 200k) and it saved 140k meat per run to use a sideclan for bucket and 10k a day to properly use the hottub.

That is, without this change I would open an instance, use a big bundle of chamois to put 100 in the bucket, do the instance in 240 turns, using up 30 chamois and leaving 70 in the bucket. I would then close the instance and start a new one, repeating the process. Wasting 70 out of every 100 chamois I mallbuy. And that is terrible. So I made this modification to the script.

To install, first type in gCLI
Code:
svn checkout svn://svn.code.sf.net/p/slimetube/code/
to get the dependencies.

Then afterwards download: View attachment relay_slime.ash
And copy paste it into your directory: /mafia/relay/
and select to overwrite the existing file.

====
Question, is anyone still maintaining the SVN? and if so, are they interested in merging these updates?
 
Last edited:

HariSeldon

New member
I tried to use this for the first time yesterday.
Had a problem with too many cases of htmlform.ash but I was able to solve that.

This is working intermittently. Sometimes it works. Other times it fails to run with an error message of "No Matching CCS found".
I am using SmartStasis.ash as my ccs.
Odd enough it says it can't find my ccs but why does it work sometimes and other times not?
 
Top