Slime Tube Adventuring Script

Theraze

Active member
Unfortunately the current version of the script has two } rather than one. Just delete the one on the end of line 113 and the script should run again.
 

DeadlyAngel2011

New member
Perhaps I am simply using the script wrong, but I can't get it to run properly. It refuses to equip my minimum ML outfit, saying 'Your low ML outfit doesn't bring your ML low enough to survive the first turn of Coated in Slime!' But that outfit gives -175 ML. I made sure the outfit name in the script and in the game match up.

It also keeps telling me to set my combat action to something sane. I just have it set to attack the big guys. I'm level 61; I can hit a ~2000ML slime. It feels like I just don't understand what the script is trying to do.
 
Last edited:

Bale

Minion
Can you equip everything in your outfit with your current stats? Equip the outfit from the relay browser and confirm that there wasn't a message about some of the outfit not being able to be equipped.
 

DeadlyAngel2011

New member
I can indeed equip everything.

That said, it now works perfectly. I'm not sure why. Maybe because I closed everything and restarted it? Maybe not.

Either way, thank you for maintaining this script. I appreciate it. I'm looking to do some Slimeling runs with my clan, and doing everything manually would be tedious.
 

Sytras

Member
This script is erroring out in r17388, possibly due to the recent monster changes.

Bad monster value: "slime1" (relay_slime.ash, line 127)

Looking at that part of the script, it seems to be calculating the HP of a single slime for use in later calculations, but Kolwiki says that different slime monsters appear in the tube depending on your ML, so I'm not sure what to replace it with.

Should this be an if/else based on your current ML?
 
Last edited:

Magus_Prime

Active member
It's the change made in r17381. The names of the monsters changed from slime1 - slime5 to: Slime, Slime Hand, Slime Mouth, Slime Construct, and Slime Colossus. I'm not able to test right now but my guess is that editing the script and replacing instances of "slime1" with "Slime", etc.. would get you back in action.
 

Bale

Minion
Alhifar has granted me commit access for this script so I made that change for him. All you need to update the script is to use the CLI command:

svn update
 

wojuff

New member
Hi, I used to use this script back in the day and it was great but now it does not seem to show up in my scripts and when i try to run it in cli it says unable to invoke. was wondering if the script is just out of date, if so, oh well and thanks for all the easy slime runs I got out of it.
 

Sytras

Member
wojuff, I use it in the relay browser. IN the "run script" dropdown in the upper right corner of the center pane, select slime and it should take you there.
 
If you click Scripts->Script Manager, then click the Manage tab and is Slime Tube listed there? If not click Install, then Slimetube then install and install it. Then reload your Relay browser. If it still does not show post the log of the cli when you did the install.
 

wojuff

New member
it is in there, I reinstalled it again. Still the same.
> svn checkout svn://svn.code.sf.net/p/slimetube/code/

Starting Checkout...
Validating repo...
Repo validated.
C:\Users\Jimbob Squarepats\Downloads\svn\slimetube
A svn://svn.code.sf.net/p/slimetube/code/relay
A svn://svn.code.sf.net/p/slimetube/code/relay/relay_slime.ash
A svn://svn.code.sf.net/p/slimetube/code/dependencies.txt
svn://svn.code.sf.net/p/slimetube/code
At revision 15

Successfully checked out working copy.
Pushing local updates...
relay_slime.ash => C:\Users\Jimbob Squarepats\Downloads\relay\relay_slime.ash
Done.
Requests complete.
 
The file is not in the directory C:\Users\Jimbob Squarepats\Downloads\relay\relay_slime.ash?

Can you post a directory listing of that directory?
 

fronobulax

Developer
I am not in a position to check this, but there was a period when KoLmafia had some problems on Windows machines when the pathname to directories of interest to KoLmafia contained a space. I thought it was fixed but it might be useful to try this on a path with no spaces. Grasping at straws but...
 

wojuff

New member
txrangersxx it was but I moved it somewhere without spaces to try what fronobulax suggested, still no luck.
directory list :
Directory of C:\Users\Luke\Downloads\relay

27/06/2017 15:06 <DIR> .
27/06/2017 15:06 <DIR> ..
27/06/2017 14:44 1,248 barrel_sounds.js
27/06/2017 14:44 2,729 basement.js
27/06/2017 14:44 343 basics.1.css
27/06/2017 14:44 9,873 basics.js
10/06/2017 11:59 364,809 bumcheekascend v0.55.ash
10/06/2017 12:03 48,532 canadv.ash
27/06/2017 14:44 3,140 chat.html
27/06/2017 14:44 4,814 cli.html
27/06/2017 14:44 2,935 combatfilter.1.js
27/06/2017 14:44 2,854 hotkeys.js
10/06/2017 12:03 18,820 htmlform.ash
27/06/2017 14:44 907 ircm_extend.js
10/06/2017 12:03 93,064 jquery1.10.1.min.js
27/06/2017 14:44 7,227 macrohelper.3.js
27/06/2017 14:44 466 onfocus.1.js
27/06/2017 15:06 0 print.txt
18/06/2017 07:17 2,421 relay_bumcheekascend.ash
13/06/2017 23:09 96,277 relay_EoDSCAscensionSettings.ash
13/06/2017 23:09 40,939 relay_OCD_dB_Manager.ash
27/06/2017 14:58 27,378 relay_slime.ash
25/06/2017 23:54 16,612 relay_Universal_Recovery.ash
27/06/2017 14:44 17,917 sorttable.2.js
27/06/2017 14:44 274 stationarybuttons.1.css
27/06/2017 14:44 205 stationarybuttons.1.js
24 File(s) 763,784 bytes
 
Top