ZLib -- Zarqon's useful function library

Magus_Prime

Active member
The SSL certificate used by https://zachbardon.com/ expired yesterday. Now anything that calls zlib generates the following error in the gCLI "There was a problem accessing the Map Manager".

As a temporary measure change:

Code:
   string rem = visit_url("https://zachbardon.com/mafiatools/autoupdate.php?f="+fname+"&act=getver", false);

to

Code:
   string rem = visit_url("http://zachbardon.com/mafiatools/autoupdate.php?f="+fname+"&act=getver", false);
 

fronobulax

Developer
zarqon noted in the UR thread that he has an expired cert and is working on that.

I noticed that a file that is supposedly up to date is two years older on my disk than on the server. I will investigate once the cert is up to date in case that is a script error and not an operator error :)
 

gausie

D̰͕̝͚̤̥̙̐̇̑͗̒e͍͔͎͈͔ͥ̉̔̅́̈l̠̪̜͓̲ͧ̍̈́͛v̻̾ͤe͗̃ͥ̐̊ͬp̔͒ͪ
zachbardon.com seems to be down at the moment!
 

fronobulax

Developer
zachbardon.com seems to be down at the moment!

Was up for me this morning and responded for me just now.

Next time it might be helpful to distinguish between "can't access from a browser or can't ping" kind of down and "KolMafia and scripts can't fetch files from" down. The latter was a recent problem that resulted from an expired SSL cert. If you were seeing the latter some kind of cache clearing might help.
 

gausie

D̰͕̝͚̤̥̙̐̇̑͗̒e͍͔͎͈͔ͥ̉̔̅́̈l̠̪̜͓̲ͧ̍̈́͛v̻̾ͤe͗̃ͥ̐̊ͬp̔͒ͪ
Was up for me this morning and responded for me just now.

Next time it might be helpful to distinguish between "can't access from a browser or can't ping" kind of down and "KolMafia and scripts can't fetch files from" down. The latter was a recent problem that resulted from an expired SSL cert. If you were seeing the latter some kind of cache clearing might help.

It was the former, and downforeveryoneorjustme was also reporting a timeout! But glad its back

EDIT: It seems my VPN was causing this locally? Weird that it also didn't work for downforeveryoneorjustme. Hmmmm
 
Last edited:

adeyke

Member
I've also been having problems. In KoLMafia, I'd just been getting long delays followed by "There was a problem accessing the Map Manager" error messages. With my browser, I've been getting connection timeouts. I can ping the server successfully. And if everything is working for other people, I don't know what the problem or solution would be.
 

fronobulax

Developer
I've also been having problems. In KoLMafia, I'd just been getting long delays followed by "There was a problem accessing the Map Manager" error messages. With my browser, I've been getting connection timeouts. I can ping the server successfully. And if everything is working for other people, I don't know what the problem or solution would be.

The usual suspect would be your system or network. Since you time out, are you using a VPN? Is your ISP having outages? Does a tracert (or traceroute or equivalent) to zachbardon.com identify a problem in the routing? The usual clear cache, check localhosts, your DNS settings, any special routing etc. probably don't apply since mafia is using a host name and you can ping by name, but... Mafia will use https so did you try that in the broswer? If there is an old certificate cached somewhere that could be a problem.
 

adeyke

Member
My Internet connection in general is fine. It's just with that server in particular that I have problems. The route is 7 hops and takes 130ms. When I use my smartphone over WIFI, I get the same connection timeout, so it's probably not my PC's settings. All of that with both http and https.

When I turn off WIFI and use my mobile data, it's a bit different. Using http returns a blank page, while using https gets me a "Secure Connection Failed".
 

fronobulax

Developer
13 hops, ~200ms, one timeout.

The routing is almost certainly going to be different between wifi (and thus an ISP) and mobile data (which at some point is almost certainly a different ISP).

The cert for the site expired a few weeks ago and it is possible something along one, or both, of your paths is using the old one but if that is the case it is not trivial to find out where and then get the cache updated.

I'm out of ideas. Networking was never a core area for me. I had minions who would solve the problems or would try and teach me how to solve them myself. Usually I learned enough to be dangerous, but not enough to be useful and so they got to clean up after me :)
 

manyakimm

New member
Server announcement here, with apologies to our Russian users.

Hi,
Before i was having a problem with Map Manager too and your solution of daily checks solved that.
But recently I deleted and installed kolmafia again and i no longer have old map manager files. Now i am getting this error:
"There was a problem accessing the Map Manager.
Restorative data is corrupted or missing. Troublesome!"

Is there something i can do about it?
 
Last edited:

zarqon

Active member
Yeah, people that lack the maps entirely are still unable to get them.

As a temporary fix, here are all the maps in my data folder which are also on the Map Manager. Unzip this in your new mafia installation's data directory. If there are any others that you still need after this, let me know and I'll add them.
 

Attachments

  • managermaps.zip
    63.1 KB · Views: 23

manyakimm

New member
Thanks for the help zarqon. The zip file you shared had solved some problems but i was still getting stuck after 1 turns with the Map Manager and corrupted data error. I wasn't sure which map i was missing so i managed to connect https://zachbardon.com/mafiatools/autoupdate.php with an USA proxy through explorer and downloaded all txt files to data folder.
Right now it seems, everything working to be in order. I'm not sure what was i missing before.
 

Pazleysox

Member
Code:
IOException during data post 
(https://zachbardon.com/mafiatools/autoupdate.php?f=recoveryScript_map_v2&act=getver): Connection timed out: connect.

Kept getting this error today. Turned a 25 minute playtime into almost 3 hours. :(
 

zarqon

Active member
My best guess is you have an old version of UR that doesn't use ZLib. The current version of UR on SVN, however, does use ZLib and should only fail to load the map once per day, turning a 25 minute playtime into a 26 minute playtime. Did you try updating?

EDIT: Also, I'm messaging the host about the server issues. They seem a bit more frequent of late, so hopefully all is well over there.

EDIT EDIT: It was an outage. The host is also tired of these problems and has moved the server virtual. So, new DNS stuff needs time to settle but then everything should work that worked before.
 
Last edited:

zarqon

Active member
Done in r43. While I was at it, I also considered HP restores to not be_good() as a Plumber, unless they are mushrooms or also restore MP.
 

Pazleysox

Member
Got this error today. ran svn update, got error again. I will look into it myself for a bypass so I can play

Code:
Bad coinmaster value: "Mushroom District Item Shop" (zlib.ash, line 403)

for my needs, I commented it out, I'm not in a plumber run now. Or ever for that matter.

EDIT - I was running a very old version of mafia.
 
Last edited:
Top