Upcoming site updates

fewyn

Administrator
Staff member
That was an accident specfic to the Developer group. It's no longer required.
 

xKiv

Active member
1) I see "read" status of messages did not migrate. This is ultraminor issue, especially if it was not supposed to migrate.
2) Are there color schemes? I liked the blue&gold. Now I need a few seconds to realize which site I am looking at >_>
 

fewyn

Administrator
Staff member
1. Not they did not migrate sadly.
2. There will be more colour schemes, probably in the coming days.
3. Almost finished with the build system should be Soon™
 

AlbinoRhino

Active member
It's asking for credentials...use the same as the forum?

edit: Nope. Invalid username or password
And there is no "create account" link that I can see.
 

gausie

D̰͕̝͚̤̥̙̐̇̑͗̒e͍͔͎͈͔ͥ̉̔̅́̈l̠̪̜͓̲ͧ̍̈́͛v̻̾ͤe͗̃ͥ̐̊ͬp̔͒ͪ
Well isn't this fancy! Thanks fewyn!!
 

Magus_Prime

Active member
Two questions on the new forum software to which I have not yet found answers:
  1. URLs to things off-site display as a broken image graphic. See fewyn's posts above.
  2. No matter how wide my browser window the size of the content displayed, be it the main kolmafia.us listing of all the sub-forums or a message thread, doesn't expand past a certain point. It will shrink if the browser window does but not expand.
Thoughts?
 

fewyn

Administrator
Staff member
Two questions on the new forum software to which I have not yet found answers:
  1. URLs to things off-site display as a broken image graphic. See fewyn's posts above.
  2. No matter how wide my browser window the size of the content displayed, be it the main kolmafia.us listing of all the sub-forums or a message thread, doesn't expand past a certain point. It will shrink if the browser window does but not expand.
Thoughts?
Can you show me a screenshot of both? First one I'm not seeing. Second one I think is normal for the default skin.
 

Magus_Prime

Active member
I just figured out the first issue. I had a browser plug-in that was blocking sigs.kingdomofloathing.com.
Where can I change the skin? I looked through the preferences before I posted and didn't see anything.

1604951393473.png

Note all the white-space in a wide browser window.
 
Last edited:

MCroft

Developer
I was required to enable two factor authentication, which is fine, but might surprise folks.

But Thank You!!!
I was also, and promptly turned it off and all is fine. An email for every device every month that I connect from is (IMHO) too much for a system that doesn't handle money. I'm cool with the option for anyone who wants it, but I don't want it for me.

The whole thing is bright and shiny and I'm liking it. Thanks for doing this.
 

AlbinoRhino

Active member
Is the wiki supposed to be up and running? I keep getting this at the moment...

Fatal error: Uncaught Error: Call to undefined method ModernTemplate::cactions() in /var/www/wiki/skins/Modern/SkinModern.php:75 Stack trace: #0 /var/www/wiki/includes/skins/SkinTemplate.php(129): ModernTemplate->execute() #1 /var/www/wiki/includes/skins/SkinTemplate.php(144): SkinTemplate->generateHTML() #2 /var/www/wiki/includes/OutputPage.php(2615): SkinTemplate->outputPage() #3 /var/www/wiki/includes/exception/MWExceptionRenderer.php(153): OutputPage->output() #4 /var/www/wiki/includes/exception/MWExceptionRenderer.php(65): MWExceptionRenderer::reportHTML() #5 /var/www/wiki/includes/exception/MWExceptionHandler.php(106): MWExceptionRenderer::eek:utput() #6 /var/www/wiki/includes/exception/MWExceptionHandler.php(185): MWExceptionHandler::report() #7 /var/www/wiki/includes/exception/MWExceptionHandler.php(156): MWExceptionHandler::handleException() #8 [internal function]: MWExceptionHandler::handleUncaughtException() #9 {main} thrown in /var/www/wiki/skins/Modern/SkinModern.php on line 75
 

fewyn

Administrator
Staff member
The wiki has been giving me a bunch of problems. I'm trying to figure out what to do with it still, was running a pretty old version and tried updating everything yesterday.
 

fewyn

Administrator
Staff member
Wiki should be working, syntax highlighting no longer works but all the code blocks are there. If anyone is interested and wants to create a lexer for https://pygments.org/docs/lexerdevelopment/ would probably help bring it back.

You also are probably going to have to re-register your account on the wiki. Let me know if anyone has any issues!
 

AlbinoRhino

Active member
The wiki has been giving me a bunch of problems. I'm trying to figure out what to do with it still, was running a pretty old version and tried updating everything yesterday.

Yeah...I was hesitant to even ask the question b/c I thought that may be the case.
I was subscribed to the changes RSS feed and saw that you suddenly got flooded with spammers creating accounts and posting garbage.

In any event, appears to be working for me now! Thanks a ton.
 

zarqon

Active member
I was unable to edit an existing post because although my edit removed text, it exceeded the character limit. Any chance of bumping it?
 
Top