Page 2 of 31 FirstFirst 1 2 3 4 12 ... LastLast
Results 11 to 20 of 309

Thread: BatMan Relay -- more info, less clicking

  1. #11
    Minion Bale's Avatar
    Join Date
    Jun 2008


    @Bale: That's odd, since as you know I'm also an Opera user, and I developed this script using almost entirely Opera. Are you using any Greasemonkey scripts that might conflict? Do you get any errors in the Java console when visiting the page?
    Originally Posted by zarqon View Post
    None of that. (Where is this java console?) I don't use any userscripts these days, though there are a few extensions. I tried disabling anything that might conflict..

    However, there is one other really weird thing. Right before every fight I see this:

    New Version of BatBrain Available: 1.23
    Upgrade from 1.21 to 1.23 here!
    Two weird things about that. The first is that I don't see that if I automate the fight with DAM which uses BatBrain; only if I use the relay override. The second weird thing is that I updated BatBrain yesterday. Here's a snippet from zversions.txt

    batbrain	1.23	20120429
    batmanrelay	1.0	20120429
    map_batfactors.txt	2012-04-23T11:40:07-05:00	20120429
    SS	3.15	20120429
    zlib	r35	20120429
    That's pretty clear.

    Why am I still getting that update message and why is it only triggered by using batmanrelay.
    Last edited by Bale; 04-29-2012 at 06:03 AM.
    If people like my scripts, please send me stuffed Hodgmen.
    Universal Recovery, OCD Inventory Control, CounterChecker, newLife, ChIT.

  2. #12


    I saw the same BatBrain update message. "1.21" isn't in any files for me except a bumcheekcity data file, so it makes no sense.

    This script made fight.php go from under 1 second to load up to 10 seconds to load.

  3. #13
    Senior Member
    Join Date
    Feb 2009


    I love it! Except, when I click on again or adventure again, i'm getting 2 combats, the first one is automated w/ my ccs, the 2nd one loads the bat brain screen and lets me do combat manually. Not particularly ideal atm. :/

    The other issue I'm suddenly having is when I try to automate barrrney's barr, even though I have the outfit equipped, mafia is telling me that area is not available, altho, I'm adventuring there in the relay browser. ??
    Last edited by Weatherboy; 04-29-2012 at 08:26 AM.

  4. #14


    Follow the instructions in the first post and unzip the file in Mafia's \relay folder. You don't need to call the scripts, the are relay overrides, and Mafia calls them automatically when it loads the page.

    EDIT: or maybe disable Mafia's combat bar, if you did unzip the files in the right place.
    Originally Posted by slyz View Post
    Done and done.

    Hmmm, I was going to tell zanmatoer that he should make sure he enabled relay overrides in mafia's Preferences menu, but when I just checked I couldn't see that option anymore. I couldn't even find the preference using "prefref". Are relay overrides enabled by default now?
    Originally Posted by zarqon View Post
    Indeed, recently was trying to help a mafia newbie to run a relay script, and searched for the option for about 15 minutes before checking here that it was in fact on by standard.

    Still no luck.

    Other possibly pertinent info:
    I got it to work with a multi! Looks super cool, if a bit overwhelming. As far as I'm aware there are no significant configuration differences between the main and multi.

    My main is a level 31 AoBoris with access to a crapton of combat items. Multi was in-run, used the script to fight the NS

    Don't know what else could be relevant?

    Thank you coders for a fantastic tool and scriptwriters for all the scripts that enhance it!

  5. #15
    Senior Member Winterbay's Avatar
    Join Date
    Feb 2010


    Did it fail to load the script for you main or just took a very long time? (with lots of itmes it'll take a while to get teh page to load I think)
    My scripts:
    Best sushi for Profit
    Winterbay's Helpful Automatic Monsterbasher (WHAM)

    Scripts maintained by me:

    A small programmer joke:
    Wife: Honey, please go to the market and buy 1 bottle of milk. If they have eggs, bring 6.
    The man came back with 6 bottles of milk.
    Wife: Why did you buy 6 bottles of milk.
    Man: Because they had eggs...

    The 6 Stages of Debugging: 1 )That can't happen. 2) That shouldn't happen. 3) Hmmm, weird. 4) Why does that happen? 5) Oh, I see. 6 )How did that ever work?

    All programs can be optimized, and all programs have bugs; therefore all programs can be optimized to one line that doesn’t work. /Bob Fitch, Blizzard

  6. #16


    Failed to load the script. Just shows the normal fight screen as expected without BatMan relay. Loads just as quickly as before.

    Thank you coders for a fantastic tool and scriptwriters for all the scripts that enhance it!

  7. #17
    Join Date
    Nov 2008
    Paris, France


    This is pretty awesome. I could finally test it in-run (and not with a level 50 character who one-shots anything with any action). The Quick Menu is really great, especially after I realized that clicking the lightbulb or the weapon will execute all the actions proposed.

    Two small issues, which both disappear if I disabled KoL's CAB:

    - If I click the lightbulb to perform all my custom actions (currently Intimidating Bellow and rock band flyers), the actions are performed but I get a blank frame afterwards. This doesn't happen with the "spam Mighty Axing" attack action.
    - The quick menu hourglass doesn't appear

    Thanks again

    "1.21" isn't in any files for me
    Originally Posted by lostcalpolydude View Post
    I had "1.21" in BatMan's adventure.ash
    Try the Nemesis Quest Script or the FamiliarFeeder interface.
    *shakes KoLMafia tech support magic 8-ball* Update mafia to the latest daily .JAR!
    Welcome to Parenthood, Noob

  8. #18


    I had "1.21" in BatMan's adventure.ash
    Originally Posted by slyz View Post
    And now I see it too. Windows 7 search is usually reliable about this stuff. So it's a copy-paste issue.

  9. #19
    Senior Member zarqon's Avatar
    Join Date
    Nov 2007
    Seoul, Korea


    If you're having version checking issues you probably grabbed the placeholder I uploaded to create the thread. Reinstall and that should go away.

    I did not test with either of the combat bars, other than making sure this script would stay out of the way. I suppose I have to test that now.

    I haven't experienced slow loading times, unless it's the first load of the day, which does all the version checking. Are you using a "legacy" machine?

    @Zan: try this with a fresh Mafia directory (all default settings) and see if we can narrow down why it's not working for your main.
    Sig by JakAtk
    My scripts: Prefref Plus | Skillref Plus | One-Click Wossna | Om*****st (??) | Psychose-a-Matic | RandBot
    Combat suite: Best Between Battle | Mercenary Mood | SmartStasis | BatMan | BatMan RE
    For script authors: ASH Wiki | ZLib | BatBrain | CLI Links | Drag-n-Drop Inventories | CanAdv | Script Registry | Map Manager
    If you appreciate my work, help me become BAT KING OF THE WORLD! Thanks to all donators!

  10. #20


    Oh for f***s sake. My apologies, worked it out.

    I've been playing with bUMRATs, so that was set as the masterRelayOverride. Unset that, and BatMan relay works. Both relieved and annoyed that it was so gorram simple.

    Now I can use this properly, can I say that it's absolutely amazing.

    I am however experiencing the same issue weatherboy is, wherein clicking any of the possible "adventure again" links (including the hourglass) runs an adventure manually, then hands me back control for the next fight.

    Thank you coders for a fantastic tool and scriptwriters for all the scripts that enhance it!

Similar Threads

  1. Replies: 2
    Last Post: 10-06-2014, 08:42 PM
  2. Replies: 9
    Last Post: 06-01-2011, 11:08 PM
  3. StDoodle's Gum Master (relay Info Script)
    By StDoodle in forum Informational Scripts
    Replies: 0
    Last Post: 02-03-2011, 12:28 AM
  4. Info Request: Relay Overrides & fight.php
    By StDoodle in forum Scripting Discussion
    Replies: 2
    Last Post: 11-17-2010, 03:03 PM
  5. 7633 - When KoL has timed you out, clicking in the Relay ...
    By RSS Bot in forum Latest SVN Changes
    Replies: 0
    Last Post: 09-19-2009, 03:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts