Witchess Puzzle Solver

Pazleysox

Member
I know I'm late in posting this, but has anyone seen this: "No match attempted or previous match failed (witchess_solver.ash, line 104)" I get it when I try and run the script. If I have opened witchess manually, I don't get this, and the script runs fine...
 

qwertyaznman123

New member
I know I'm late in posting this, but has anyone seen this: "No match attempted or previous match failed (witchess_solver.ash, line 104)" I get it when I try and run the script. If I have opened witchess manually, I don't get this, and the script runs fine...


I just got this message too. I have the most recent build of Mafia, as well.
 

wrldwzrd89

New member
I get this as well in the exact same situations. Why it wouldn't detect that Witchess isn't active and try to go there BEFORE attempting a solution... is beyond me.
 

Pazleysox

Member
Here's what I did to combat the issue. There's probably a better way to do it, but I couldn't think of one.

Code:
void main()
{
	visit_url("campground.php");
	visit_url("campground.php?action=witchess");
	visit_url("choice.php?whichchoice=1181&option=2&pwd");  
	visit_url("choice.php?whichchoice=1181&option=1&pwd"); 
	visit_url("campground.php?action=witchess"); 

	cli_execute("call witchess_solver.ash");
}
 
Last edited:

Uli

New member
Can you post the actual error? Is line 104 part of the witchess script?


"No match attempted or previous match failed (witchess_solver.ash, line 104)"


Get the same error whether I run your rollover script or the witchess script directly, so it would seem that's where the error is happening. It is the same error you posted here in post #42 above. I tried copy/pasting your fix from post #46 into the witchess script to no avail.
 

Pazleysox

Member
"No match attempted or previous match failed (witchess_solver.ash, line 104)"


Get the same error whether I run your rollover script or the witchess script directly, so it would seem that's where the error is happening. It is the same error you posted here in post #42 above. I tried copy/pasting your fix from post #46 into the witchess script to no avail.

I remember dealing with this. I believe it happens when the script comes across a puzzle it hasn't solved for you yet. For some reason, I also think it happens before you have the full puzzle buff available too.

I used to manually go into my witchess set, and open a puzzle, not solve it, and re-run the script. If that doesn't do it, try having mafia auto solve 1 puzzle, and re-run.
 

Uli

New member
I remember dealing with this. I believe it happens when the script comes across a puzzle it hasn't solved for you yet. For some reason, I also think it happens before you have the full puzzle buff available too.

I used to manually go into my witchess set, and open a puzzle, not solve it, and re-run the script. If that doesn't do it, try having mafia auto solve 1 puzzle, and re-run.

Your suggestion helped and after opening the witchess set in my campground, opening a puzzle, then leaving, the script started back up again.


Thanks!
 
Last edited:

snooty

Member
I'm getting this today...after both manually switching the puzzle, and mafia auto-solve. Any suggestions?

Puzzle 1 complete. (#37)
Puzzle 2 complete. (#45)
Puzzle 3 complete. (#61)
Soution out of bounds!
Solution: u u r d r r u u l u u u l u u u u r u u r d d d l d d r r d l d d r d d d r u u u u u u u u u l u r u l u r ->
witchess.php?sol=&ajax=1&number=58
Could not solve puzzle 4. (#58)
Puzzle 5 complete. (#60)
Could not complete all witchess puzzles.
 
Top