Veracity's Gingerbread City.ash

taltamir

Member
Ok, I can confirm that setting my CCS to

Code:
[ gingerbread ]
skill micrometeorite
skill saucegeyser


[ gingerbread pigeon ]
skill macrometeorite
skill saucegeyser


[ gingerbread rat ]
skill macrometeorite
skill saucegeyser
resulted in it switching away rats and pigeons while killing everything else in gingertown with a saucegeyser.
However it was using at most 1 macrometeorite per adv. So with some strange luck it might be possible to not use them all up. (eg, if 18 sewer turns are 13 gators + 5 rats that turn into pigeons when used on. A human would use macro a second time during the rat->pigeon adventures, the CCS won't; but the odds of this happening are relatively low)

Also, I was under the impression advancing time only lost you a single adventure, and could then do 15 at night to compensate. But no, it actually removes those 5 adventures from your daily limit. So, I am disabling it now.
 
Last edited:

Magus_Prime

Active member
I tried to run configureVGC.ash this morning and got this in response: "Function 'print( )' overrides a library function (configureVGC.ash, line 5)". No idea why.
 

Veracity

Developer
Staff member
Because I added print() with no arguments as a built-in ASH function.
It prints a blank line. You used to have to do that with print( "" ), which annoyed me.
I'll remove the no longer necessary function from the script. Thanks!
 

hollow2201

New member
My apologies if I am missing something obvious. I have deleted and reinstalled this script. When I call it. I get this with no turns spent:

> call scripts/Gingerbread City.ash

Day 1 of quest "raygun"
Overriding midnight choice: "Judge Fudge" -> "Mysticality"
Adventuring in The Gingerbread City stops.
Farming sprinkles
Gained 0 sprinkles in 0 turns. Sprinkles/Adventure = 0
Cumulative = 362,122 sprinkles in 3,597 turns. Sprinkles/Adventure = 100
Spent 0 sprinkles. Cumulative = 4,000

I don't understand why it is aborting. Any suggestions? Thanks.
 

Terrabull

Member
When I run the script, it immediately stops now, it doesn't try to use any turns, just displays the output.

EDIT: So for some reason my configuration was all changed to none, which stopped the script from working at all with no message. Had to manually edit the files to update them.
 
Last edited:

Heleman

New member
My apologies if I am missing something obvious. I have deleted and reinstalled this script. When I call it. I get this with no turns spent:

> call scripts/Gingerbread City.ash

Day 1 of quest "raygun"
Overriding midnight choice: "Judge Fudge" -> "Mysticality"
Adventuring in The Gingerbread City stops.
Farming sprinkles
Gained 0 sprinkles in 0 turns. Sprinkles/Adventure = 0
Cumulative = 362,122 sprinkles in 3,597 turns. Sprinkles/Adventure = 100
Spent 0 sprinkles. Cumulative = 4,000

I don't understand why it is aborting. Any suggestions? Thanks.
I dunno if you ever managed to get this working but I'm getting the same sort of output:

> call scripts\Gingerbread City.ash

Day 1 of quest "blackmail+raygun"
Overriding midnight choice: "mainstat" -> "Muscle"
Adventuring in The Gingerbread City stops.
Farming sprinkles
Gained 0 sprinkles in 0 turns. Sprinkles/Adventure = 0
Cumulative = 0 sprinkles in 0 turns. Sprinkles/Adventure = 0
Spent 0 sprinkles. Cumulative = 0

If you did manage to get it working I'd love to know how, because I'm at a loss.
 

Heleman

New member
Yeah, it returned true and after that when I ran I got the same output. I did have to manually change gingerExtraAdventures to true, but that also didn't solve the problem.
 
Top