Bug Maximizer wonkiness

Xande1

Member
So, somewhere in the last five days, the maximizer has gone wonky on me. Simple expressions seem to work fine, but the full expression I use for prepping volcano mining has broken. The precise expression is: "hot res, 15 min, 15 max, +equip high-temperature mining drill, hp regen, 0.1 hp, -familiar". It worked flawlessly for a while, but now, I get results that equip weapons other than the mining drill, and also fail to get me enough hot resistance.

Removing the min and max from the expression seem to make it behave pretty much as expected (for an expression without min and max), but all the strings I try that use min do weird things.* Max alone seems better behaved, but I haven't tested enough to be sure it's working, as opposed to broken in ways I haven't caught. But at least it equips the mining drill I asked for, and seems to be maximizing the other keywords more-or-less appropriately.

Known working for me on Nov 12, but I can't tell from session logs exactly which revision I was running on that date. I've tried reverting as far back as r20494 and running the maximizer with the same string, but I get the same results as with r20501. So it's possible that there's some user error or configuration problem on my end, rather than a bug in the maximizer code. That said, I've literally copy/pasted the maximizer line from old session logs where it worked perfectly, and it's not working now, which is why I opted to put this in bugs rather than community help.

*If I manually equip hp resist, and use the simpler expression "hot res, 15 min, 15 max, +equip high-temperature mining drill, -tie" it gives me an outfit that includes the drill and enough hot resist, but it swaps my existing hat for Uncle Crimbo's Hat, my pants for Pantsgiving, and my acc3 for a Crimbolex Watch, despite the "-tie" directive. (It does slightly different things if I have different gear equipped.) Changing the "hp" and "hp regen" arguments to other stats (like myst or weapon damage) gives the same result, maximizer suggestions no longer include the mining drill at all, and don't give the requested amount of hot resist. Doing "hot res, 15 min, 15 max, +equip high-temperature mining drill" (without -tie) does even more inexplicable things, like with my current gear setup, it wants to unequip my acc3 (heart of the volcano), and not replace it with anything.
 

Attachments

  • Screenshot from 2020-11-17 13-44-21.png
    Screenshot from 2020-11-17 13-44-21.png
    70.9 KB · Views: 3

MCroft

Developer
Well, I touched the Maximizer and I’m going to revert one of my changes to buy myself time to fix this right. Will be in a few hours, though.
 

Xande1

Member
No rush. I mean, I want it to work again at some point, but now that everyone (including me) knows what's going on, I can work around it until an update comes. Thanks much.
 

MCroft

Developer
I've got two issues posted and nobody wants the maximizer to accidentally spend all their lucre, so I want to give myself more time. I have an appt. in 20 minutes, and it's my next task after that's done.
 

Xande1

Member
Logging in now, so I'll give it a whirl and report back. Thanks!

EDIT update: That turned out to be a really long aftercore day. Everything in maximizer seems to be working as expected for me now. Thanks, MCroft!
 
Last edited:
Top