Bug MacOS Big Sur KoLmafia.app fails to launch

MCroft

Developer
I was testing the release process for another change and it builds the .jar, the .app, and the .dmg, but the .app won't launch for me on Big Sur (MacOS 11.0.1)

Code:
Dyld Error Message:
  dyld: Using shared cache: 9F6FFF1F-4096-355B-B037-8DCE73A7AA42
Library not loaded: /System/Library/PrivateFrameworks/JavaApplicationLauncher.framework/Versions/A/JavaApplicationLauncher
  Referenced from: /Users/USER/*/KoLmafia-20.7.app/Contents/MacOS/JavaApplicationStub
  Reason: image not found

It looks like this has moved to a private framework that is no longer in /System/Library.

We could include it, but we might need a fix/change to jarbundler.jar (which is on GitHub, but hasn't been active lately).

Also, I saw the Java 7+ jarpackager stuff, which would be 200+MB bigger (because it includes the JRE) but which gives a single-click app with no dependencies (because it includes the JRE). I am not advocating that, but maybe eventually ...
 

fronobulax

Developer
Last commercial app I worked on bundled the JRE with the app. When it worked, it was great, but there were sometimes user system conflicts. It was also hard for developers to debug. We all had our own JREs and could do our testing but the app wasn't tested until QA/QC had done their thing on a machine without a JRE. It didn't happen often but there were cases where something would fail on the QA/QC machine but not on the machine of the developer assigned to fix it.

Now if a bundled KoLmafia would run on an Android...
 
Top