Now that we support JS,Tour Guide, available from https://github.com/cdrock/TourGuide/branches/Release installs both relay_TourGuide.ash and relay_TourGuide.js in /relay.
This results in two entries labelled TourGuide in the relay browser run script dropdown. While the author could have made different choices this raises the question of how to handle similarly named scripts? Since an ash script and a js script are two different things, I think there is a feature request to distinguish between the two types in menus.
And, when I run relay_TourGuide.jsI I get
and at this point I cannot tell whether that is a scripting error or an implementation error so am reporting it here.
relay_should be reserved for scripts that are to be executed by the mafia interpreter not the browser. The feature request should be to rename relay_TourGuide.js to TourGuidIne.js or similar