Bug - Fixed Incorrect drunkenness warning with base of 20.


New member
My main (djve in game) has a base of 20 drunkenness (14 base + 5 liver of steel +1 Drinking to Drink) but on adventuring with 20/20 I get the message:
KoLmafia has detected that you are about to adventure while overdrunk. If you are sure you wish to adventure in a Drunken Stupor, click the icon to adventure.

I'm assuming this would also be an issue if I added Hollow Leg (via Sloppy Jalopy).

I don't remember this happening in the previous build, 50559.

Currently running: KoLmafia v20.7 r20562

Not a big problem but should be trivial fix.


Staff member
OK, I'm looking for this.

It seems as if that warning only gets sent if KoLCharacter.isFallingDown() is true in relay request (which was touched in 50550, but not in anything that should affect this). Given that message, I'm assuming you're in the relay browser.

isFallingDown checks return KoLCharacter.getInebriety() > KoLCharacter.getInebrietyLimit()

getInebrietyLimit has base of 14, + 5 for liver, +1 for drinking to drink. It also has +1 for Hollow Leg. Since it shows you a limit of 20, that seems like it's working.

So, somehow Mafia thinks either inebriety is greater 20 or that limit is less than 20.

I am not sure what's going on.


New member
ash ash inebriety_limit()
So it's not seeing liver of steel or the Neverending Party skill. But it was fine a few days ago.

ash have_skill( $skill[ liver of steel ] )
Returned: false
ash have_skill( $skill[Drinking to Drink] )
Returned: false
ash have_skill( $skill[CLEESH] )
Returned: true


Staff member
Could you visit charsheet and post the html? Perhaps this yet another consequence of parsing skills from charsheet.



New member
To confirm it doesn't happen with the previous build 50559, I just restarted to confirm.

And you can confirm the skills from https://cheesellc.com/kol/profile.php?u=djve

And it's fixed in 50563, that just dropped. So I'll close this down. But something changed for a few hours. :)

How do I mark this as fixed in a subsequent build?


Staff member
In my ideal world, we make a test case for "has liver of steel + Drinking to drink & inebriety limit = 20" and make that part of the functional tests around skills.


New member
Attaching my HTML charsheet as requested from PhilmASTErpLus.
The compressed file is a tar (Tape ARchive) as I'm a Unix dinosaur type.
It's is the full page, saved in zip format. I think this is the most accurate dump of the data, or hope it is. Looking at the page in Safari, Chrome, and Firefox it seems good.

Upload: WTF, I tried bzip2 but, after 20 years, it's still not accepted. Weird, since it's a more effective format.


  • djve_charsheet.zip
    224.7 KB · Views: 1


Active member
Thank you. I looked at your character sheet, and didn't find anything that would cause the latest revision (r20563) to fail. If I remember correctly, the bug was introduced in r20541 and should have been fixed in r20553. Since there was no change in r20563 that could have affected this, it is possible that the bug still persists.

@djve Just in case, could you please double-check that KoLmafia returns false for ash have_skill( $skill[Drinking to Drink] ) in r20562, but true in r20563? It would be helpful in pinpointing the cause of the bug. Here's a download link for r20562.

Unrelated to the bug, there was an interesting HTML in your charsheet:

<a onclick='javascript:poop("desc_skill.php?whichskill=3&amp;self=true","skill", 350, 300)'></a><br>

This is skill ID 3, but it has no skill name, and probably isn't visible to the user at all. KoLmafia currently believes that it's supposed to be the "Old Smile of Mr. A" skill, but the KoL wiki says that it's the Pickpocket skill.

@djve I assume you don't have the "Smile of Mr. A" skill? Did you happen to have some effect or equipment that grants Pickpocket, e.g. Form of Bird or Riboflavin?
Last edited:


New member
Sorry for the delay, RL and then Crimbo.
I do have the Smile of Mr. A skill. I was an TT when posting. I don't know about the "Old Smile", but I've have a Golden Mr. A for some time.

Confirmed "false" in 50562, and "true" in 50563 and 50588


New member
Sorry for bumping an old thread, but I (Zfish9 #2294779) also have this problem. I'm currently playing through G-lover and I'm at 20/20 drunkenness, but kolmafia insists I'm at 20/15. At one point when I changed outfits it went down to 20/14, but I am have trouble reproducing that.

I can adventure manually just fine, I just can't auto adventure anywhere ("You are too drunk to continue.")

ash inebriety_limit() returns 15.
ash have_skill( $skill[ liver of steel ] ) and ash have_skill( $skill[Drinking to Drink] ) both return true.

I will note that mafia also thinks my familiar's weight is 5 lbs lower than it really is ("Familiar weight: KoL = 36 KoLmafia = 31"), but that's not hurting anything on my end.

I am on r27696. I tried going back as far as r27688 and still had issues. I did not have this issue in this path a few days ago on an older build from around August or September (It was absolutely before the October and November iotms). I wish I could give the exact version I was using, but I deleted it like a fool when I downloaded the newest update.


Staff member
You're most likely running into the issue from https://kolmafia.us/threads/you-are-too-drunk-to-continue.29307 where sometimes the passive skill modifier cache gets out of sync with Mafia's understanding of your skills.

This became especially visible with r27601 (Sep 16; stomach / liver / spleen capacity started being tracked as modifiers), but the issue has been around since r26962 (Nov 18, 2022, when the cache was introduced).

A workaround is to type "modtrace liver capacity" into the graphical CLI when you notice this issue (since that will forcibly recompute the passive skill cache), but that won't help me get to the bottom of the problem :(