Greasemonkey Relay Browser Support

holatuwol

Developer
Because people seem to be poking GM script writers a lot more often to convince them to include KoLmafia relay browser support, I decided to save everyone time and modify Greasemonkey itself to provide that support automatically. So, if you trust the modified source code enough (I added maybe 12 lines to greasemonkey.js in the components folder in the Greasemonkey source code), you're more than welcome to install the modifications.

To do so, download the attached file to your desktop. Then, drag and drop the downloaded XPI into Firefox (if it's attached as a ZIP, simply rename it to XPI after downloading). This will prompt you for installation. After installing the add-on and restarting Firefox, all Greasemonkey scripts that were only injected into KoL pages should now also be injected into KoLmafia's relay browser.

There is, however, one caveat: the relay browser pages will not be explicitly listed in the include pages. This is to leave it clear that the scripts do not necessarily handle KoLmafia's injections, or even KoLmafia's need to have the port be explicit. Therefore, because they were not intended to be included in KoLmafia's relay browser, you should under no circumstances bother the script writer about their script not working under KoLmafia.
 
Last edited:

dangerpin

Minion
Well, I hate to tell you this. Holatuwol was the primary driving force behind GM compatibility with Mafia and he is taking a long and perhaps (though I truly hope not) permanent vacation from making updates.
 

Muhandes

New member
sadface

Well, at least the current update does not seem to be that big, living with the old version should be OK.
 

holatuwol

Developer
Greasemonkey 0.8 - 2009/01/23
(complete with preemptive support for Firefox 3.1)
 

Attachments

  • greasemonkey-0.8.20090123.1-fx.zip
    142.4 KB · Views: 143
Last edited:

Muhandes

New member
Must have faith :)

Thank you very much holatuwol.

Just to see that I installed it correctly, I renamed it to .xpi and dragged it into firefox.
 

holatuwol

Developer
Just to see that I installed it correctly, I renamed it to .xpi and dragged it into firefox.
Yes, that's the correct way to install it. The new forums didn't allow for the .xpi fiile extension for attachments (or at least, it's not listed as an acceptable extension), so I just left it as a .zip when I uploaded it.
 

housellama

New member
Clarification

Okay. I'm perhaps a bit confused.

I understand this allows for greasemonkey scripts displayed on the Relay Browser, but it also almost sounds like you can add new scripts with this. Is there a way to add scripts that work with that? Ie, Tard's new Framework stuff? Or am I completely off on that aspect of it.

-Housellama
 

Sandiman

New member
Yes, this allows for things like Tard's Framework in the Relay browser. Just make sure the "included pages" list for the user script includes *127.0.0.1 along with *kingdomofloathing.com, and everything should work just fine.
 

Muhandes

New member
Almost all GM scripts that run on a regular firefox browser can run within the relay browser if you use this version of GM. I believe Picklish's Mall Helper is the only script I have which doesn't.
 
Top