Buff Bot Meat Sending Problem

Sputnik1

New member
I recently started having a problem with sending meat to a buffbot like kolabuff lately

Sending package to kolabuff...
Transfer failed for Meat Gained: 1,125
Transfer failed for 1125 meat
Failed to send message to kolabuff

using this code

Code:
if(have_effect($effect[Ode to Booze]) < 1) 
  cli_execute ("csend 1 meat to kolabuff; csend 1 meat to Testudinata");

I dont understand why Mafia would be wanting to send over 1000 meat to a bot when I specified I want to send only 1 meat. Is there something I'm doing wrong? I never had this problem before.

It also did it for another buff when I tried sending 7 meat and it asked for 84.
 

slyz

Developer
If it worked before, and stopped working, maybe it has something to do with the latest daily builds (if that's what you're using). Try rolling back to r7859 maybe ?
 

Sputnik1

New member
yeah, i was thinking the same thing, cuz ive also had other problems showing up like problems with the modifier maximizer not equipping the appropriate adventures items
 

halfvoid

New member
i've had problems with almost every script since they made the parsing changes, i'm sticking with the build before any of that occured until i stop seeing fixes for stuff broken by that.
 

Alhifar

Member
csend converts from the cheap philantropic buff prices, such as those you are using, to the full priced buffs, to avoid people scripting access to these cheap buffs. This is a feature, not a bug.
 

Veracity

Developer
I know they arent philanthropic because they are listed in the buff list
A buff is defined as "philanthropic" if the buffbut will only let you get it once a day. ALL buffs are listed on a buffbot's buff list, philanthropic or not. The philanthropic ones tend to be cheaper.

Of course, you know that, since you picked out the 1-meat buffs, right? Why would you think that was not philanthropy?
 

Sputnik1

New member
I thought all the philanthropic ones were coded out because some of the bots didnt want to be accessed at all by Mafia, oh well my mistake
 
Top