Results 1 to 5 of 5

Thread: CLI displays corrupted HTML

  1. #1
    Junior Member
    Join Date
    Oct 2018
    Posts
    15

    Default CLI displays corrupted HTML

    From time to time when I execute something in the CLI that produces HTML output, it shows up as corrupted. Here's an example. Any suggestions as to what I'm doing wrong, or how to fix it? It seems to be intermittent.

  2. #2
    Developer
    Join Date
    Apr 2010
    Posts
    4,872

    Default

    That is trying to display more than there is room for. Either make the window wider or use a more specific modtrace, such as modtrzce muscle experience, so fewer columns are generated.

  3. #3
    Developer Veracity's Avatar
    Join Date
    Mar 2006
    Location
    The Unseelie Court
    Posts
    11,447

    Default

    Yes. Java's built-in HTML renderer doesn't seem to want to wrap things within table cells. Last time I looked at that issue, I couldn't see a way to make it Do the Right Thing.

  4. #4
    Junior Member
    Join Date
    Oct 2018
    Posts
    15

    Default

    Ah, a bug in the renderer makes sense. It doesn't just happen with modtrace, I've seen it with almost anything that displays HTML. Are there any plans to add a horizontal scroll bar to the CLI? That would help some. In the mean time I guess I'll just deal with it.

  5. #5
    Senior Member AlbinoRhino's Avatar
    Join Date
    May 2008
    Posts
    843

    Default

    Is it maybe possible that this work-around https://kolmafia.us/showthread.php?2...refref-command could also be applied to the modtrace tables?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •