Bug - Fixed Published builds do not work on my system.

heeheehee

Developer
Staff member
- Antler was different.
- jni (whatever that is) was different.

If I change the relevant dep versions in build.gradle to
Code:
    runtimeOnly 'net.java.dev.jna:jna:5.6.0'
    runtimeOnly 'net.java.dev.jna:jna-platform:5.6.0'
    runtimeOnly 'org.antlr:antlr-runtime:3.4'
that just about eliminates the difference between the two versions when running diff -r on the unzipped contents. (shadowJar also pulls in antlr stringtemplate but meh)

Veracity: does that work for you? (or does it make both versions fail equally?)
 

Veracity

Developer
Staff member
I made those changes and both "gradlew jar" and "gradlew shadowJar" make .jar files which work just fine for me. I can do "svn update" and every installed script is found with no problem. svn_exists works. And so on.

Thanks!
 

Veracity

Developer
Staff member
By the way, I downloaded svnkit-1.10.6 and this is in its build.gradle:

Code:
project(':svnkit') {
    dependencies {
        compile 'org.apache.sshd:sshd-core:2.8.0'
        compile 'org.apache.sshd:sshd-common:2.8.0'
        compile 'net.i2p.crypto:eddsa:0.3.0'
        compile 'de.regnis.q.sequence:sequence-library:1.0.4'
        compile 'org.tmatesoft.sqljet:sqljet:1.1.14'
        compile 'net.java.dev.jna:jna:5.6.0'
        compile 'net.java.dev.jna:jna-platform:5.6.0'

        // TODO: Delete these abandoned dependencies: com.trilead, com.jcraft
        compile 'com.trilead:trilead-ssh2:1.0.0-build222'
        compile('com.jcraft:jsch.agentproxy.connector-factory:0.0.7') {
            exclude group: 'net.java.dev.jna'
        }
        compile 'com.jcraft:jsch.agentproxy.svnkit-trilead-ssh2:0.0.7'
        // TODO: End of abandoned dependencies

        compile 'org.lz4:lz4-java:1.4.1'

        testCompile 'junit:junit:4.8'
    }
    ...
 

Veracity

Developer
Staff member
I submitted a PR which:

- upgrades svnkit from 1.10.3 to 1.10.6 (why not?)
- eliminates antlr-runtime dependency - which has not been needed by svnkit for years
- requests the same version of jna that svnkit asks for - not a later version which does not work with it, on my system, at least.
 
Top