loopback problem, can't do relay browser


New member
This used to work fine, but now when I try to open the relay browser, kolmafia says "failed to find free port in range 60080 to 60090" and the browser says "Firefox can’t establish a connection to the server at" According to netstat -ab these ports are not being used. I tried setting relayPort to other values, but no luck. answers a ping. Temporarily disabling Firewall and other protections did not help. This problem may have been caused the May 2024 cumulative Windows 10 patches being installed today. I'm wondering if the patches messed up any necessary settings that I can manually fix. I'm running Windows 10 Pro 22H2 64-bit.


Staff member
One thing that may fix it is to restart your computer (windows icon -> power button -> restart). Shut down / turn back on is not good enough.

Chances are these ports are reserved by Hyper-V or after Windows updates. Use the command "netsh interface ipv4 show excludedportrange protocol=tcp" and see if they show up.

If they do, you can disallow using that range by following https://stackoverflow.com/a/65234135/2591803


New member
Thanks. Restart did the trick. I had not tried that because it already restarted during the Windows updates process. Now I know - the updates don't necessarily clean up after themselves.