Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13

Thread: Auto-download latest SVN version (MAC)

  1. #1

    Default Auto-download latest build (MAC)

    First it checks if you have installed the latest version. If you have it does nothing. If you doesn't have the latest version it will replace the java file inside KoLmafia.app in your applications folder.
    I made this script in applescript and here are the requirements:
    *Have KoLmafia.app located in Applications folder (Can be downloaded here: https://sourceforge.net/projects/kolmafia/files/ remember to rename "KoLmafia.14.0.app" to "Kolmafia.app")

    Update:
    *Added option to run KoLmafia after trying to update.

    Update 26. Feb 2012:
    *Fixed updating
    *Supports lion now
    *Don't download temporary version file to downloads folder

    Update 26. Feb 2012 (again):
    *Allow KoLmafia.app to be in any location
    *Ask for confirmation and quits KoLmafia if running before updating.
    Attached Files
    Last edited by tyilo; 02-26-2012 at 03:32 PM.

  2. #2
    Junior Member
    Join Date
    Oct 2010
    Posts
    4

    Default Error

    I only get an error when I run the program.

    "An error of type-- 1409 has occurred."

  3. #3

    Default

    Try using 3 more times and if you still get the error i don't know what's wrong...

  4. #4
    Senior Member
    Join Date
    Jul 2008
    Posts
    526

    Default

    This is the best I could find on that particular error code:
    Error: -1409

    Macintosh system error (-1409) * Named fork does not exist */ error

    The info we have on this error means that some part of the OS is damaged or missing, (assuming that the HD directories & such aren't messed up). Try reinstalling the last big combo update from Apple. It's possible that you will have to do an "Archive & Install" to repair your system files.

  5. #5

    Default

    Do you:
    *Have KoLmafia.app located in Applications folder (Can be downloaded here: https://sourceforge.net/projects/kolmafia/files/ remember to rename "KoLmafia.14.0.app" to "Kolmafia.app")
    *Have a folder located at /Users/<username>/Downloads/ (default Downloads folder if the system language is English)

    where Applications folder is /Applications/

  6. #6
    Junior Member
    Join Date
    Oct 2010
    Posts
    4

    Default

    Yep, everything is where it should be. Three more errors just the same.

  7. #7

    Default

    Try this version, maybe i uploaded an old version
    Attached Files

  8. #8

    Default

    Just tried the second version of your updater. Works great! Thanks for making it.

  9. #9

    Default

    np, don't even play kol anymore lol

  10. #10
    Junior Member
    Join Date
    Feb 2009
    Posts
    8

    Default

    Been using this and noticed it didn't update past version 9999.

Similar Threads

  1. Replies: 0
    Last Post: 07-26-2015, 02:30 AM
  2. Replies: 2
    Last Post: 10-01-2014, 04:15 AM
  3. Replies: 0
    Last Post: 01-29-2011, 05:20 PM
  4. Replies: 0
    Last Post: 11-03-2010, 11:10 PM
  5. Can't download ASH
    By yourkie1921 in forum Community Support
    Replies: 6
    Last Post: 12-11-2007, 09:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •