KoLmafia was initially coded to require Java 1.5. Back in the day, that was recent and supported.

We later upgraded to require 1.6, having concluded that machines that couldn't run that version were vanishingly few and were, essentially obsolete.

Now, many years later, 1.6 has been end-of-life for a while and it is long since time to adopt a more modern Java version.

We chose version 1.8 - Java 8.

Chances are, if you have been keeping your Java up to date - always recommended, since they always improve security, if nothing else - you already have a suitable Java runtime and KoLmafia will continue to Just Work for you.

If your Java is too old, you'll get an error trying to start KoLmafia. Update Java to 1.8 and all will be golden.