Page 2 of 2 FirstFirst 1 2
Results 11 to 15 of 15

Thread: Ant build failed (AbstractPainter.class error)

  1. #11
    Developer fronobulax's Avatar
    Join Date
    Feb 2009
    Location
    Central Virginia, USA
    Posts
    4,729

    Default

    I will run whatever version of Java is needed. The days when I had to be compatible with a work environment on this machine are past.

    I have been making a distinction between a compile environment and a run environment. I am under the impression that if I compile and build on version X with the appropriate switches, the resulting jar file can run on version Y where Y <= X.

    If that is correct then I think the devs can decide to upgrade without any impact on users. The historical reasons for not upgrading the devs were rooted in Java versions and Mac support and at least one dev who could not upgrade. Those days are long gone, I believe.

    If I am wrong then we should probably start a thread elsewhere and see if any users here have concerns about requiring a runtime of 7 or 8.

  2. #12
    Senior Member MCroft's Avatar
    Join Date
    Feb 2009
    Posts
    103

    Default

    Looks like you can’t use lambdas with the java 6 JRE, with caveats (e.g. you could use retrolamdba or something).

    https://stackoverflow.com/questions/...arlier-version

  3. #13
    Developer fronobulax's Avatar
    Join Date
    Feb 2009
    Location
    Central Virginia, USA
    Posts
    4,729

    Default

    Looks like you can’t use lambdas with the java 6 JRE, with caveats (e.g. you could use retrolamdba or something).

    https://stackoverflow.com/questions/...arlier-version
    Originally Posted by MCroft View Post
    Thanks. Sounds like the proposal would be either the status quo or to raise the source compatibility to (at least) Java 8 and the target/required runtime to be Java 8 as well.
    Well, thank you.
    Originally Posted by Veracity View Post

  4. #14
    Developer Veracity's Avatar
    Join Date
    Mar 2006
    Location
    The Unseelie Court
    Posts
    13,407

    Default

    raise the source compatibility to (at least) Java 8 and the target/required runtime to be Java 8 as well.
    Originally Posted by fronobulax View Post
    I would like this.
    Ph'nglui mglw'nafh Cthulhu
    R'lyeh wgah-nagl fhtagn.

  5. #15

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •