20521: Implement `require` so that ash and other JS scripts can be imported in JavaScript. Thanks...

RSS Bot

Feed Reader
Implement `require` so that ash and other JS scripts can be imported in JavaScript. Thanks @ikzann.

Also I fixed a few minor IntelliJ code analysis issues

by innerdreams on 2020-11-23 16:15:56

M /src/net/sourceforge/kolmafia/KoLmafiaCLI.java (view) (diff)
M /src/net/sourceforge/kolmafia/textui/AshRuntime.java (view) (diff)
M /src/net/sourceforge/kolmafia/textui/DataFileCache.java (view) (diff)
A /src/net/sourceforge/kolmafia/textui/javascript/AshStub.java (view)
M /src/net/sourceforge/kolmafia/textui/javascript/JavascriptRuntime.java (view) (diff)
A /src/net/sourceforge/kolmafia/textui/javascript/LibraryFunctionStub.java (view)
A /src/net/sourceforge/kolmafia/textui/javascript/SafeRequire.java (view)
A /src/net/sourceforge/kolmafia/textui/javascript/UserDefinedFunctionStub.java (view)
M /src/net/sourceforge/kolmafia/textui/javascript/ValueConverter.java (view) (diff)
 
Top