Disable allowSocketTimeout since it is harmful. The default for the option was false, but players who
were using KoLmafia before I changed the default from true to false had it at false.

I left in the code, for study, but the option to enable it is ignored and it is always disabled.

by veracity0 on 2019-09-05 16:36:55

M /src/net/sourceforge/kolmafia/request/GenericRequest.java (view) (diff)