Results 1 to 5 of 5

Thread: Kolmafia won't work on my Macbook Air 2015.

  1. #1

    Default Kolmafia won't work on my Macbook Air 2015.

    I tried downloading the latest jar build, and I face two major issues.

    Firstly, it may get stuck at retrieving campground data and not log in at all.

    If it manages to log in, whatever scripts I run will just abruptly not move and stay stagnant. I can't even stop the script by pressing the escape button.

    Is there something I'm doing wrong with mafia or is it just unsuitable for a mac?

    I have gave it enough time to load thinking maybe the command took time, but 1 hour for a meat.enh buff seems pretty wrong.

    Thank you!

  2. #2
    Developer fronobulax's Avatar
    Join Date
    Feb 2009
    Location
    Central Virginia, USA
    Posts
    4,091

    Default

    Hmmm. This is similar to other reports that AFAIK (alas) have not been resolved. The expectation is that KoLmafia will work on your Macbook.

    What version of Java is on your machine?
    Is there anything unusual in your session logs?
    If you have multiple characters, does it 'fail' for all of them or just one?
    Have you tried disabling various scripts and observing whether the behaviour changes?
    Do you have "a lot" of different items in your inventory?
    Do you use Java for anything else on your machine and, if so, do those applications work as expected?
    Are there any network performance issues? Do things work as expected when you log into KoL in a browser, without mafia?

  3. #3

    Default

    Hmmm. This is similar to other reports that AFAIK (alas) have not been resolved. The expectation is that KoLmafia will work on your Macbook.

    What version of Java is on your machine?

    the latest.

    Is there anything unusual in your session logs?
    no, it just stops all of a sudden, like changing familiars, and it gets stuck there with no error message whatsoever

    If you have multiple characters, does it 'fail' for all of them or just one?

    only one account, and it fails.

    Have you tried disabling various scripts and observing whether the behaviour changes?

    ive tried volcano mining, cc ascend, even a simple cc snapshot, all pauses within 5-10 commands.
    Do you have "a lot" of different items in your inventory?

    most of my stuff are in my closet. ive played for 9 years so i have lots of stuff. but that doesnt seem to be the issue.

    Do you use Java for anything else on your machine and, if so, do those applications work as expected?

    only coldfront marketpalce, and it works fine.

    Are there any network performance issues? Do things work as expected when you log into KoL in a browser, without mafia?

    network is fine and it all works well on browser.
    Originally Posted by fronobulax View Post

    I'd be willing to pay 100m to whoever can resolve this issue, you can find me in game as YetAnotherMain #1896439.

    this is really irritating my experience hahaha.

  4. #4
    Developer fronobulax's Avatar
    Join Date
    Feb 2009
    Location
    Central Virginia, USA
    Posts
    4,091

    Default

    I'd be willing to pay 100m to whoever can resolve this issue, you can find me in game as YetAnotherMain #1896439.

    this is really irritating my experience hahaha.
    Originally Posted by yetanothrmain View Post
    If this is the same problem others have reported I'm not sure the reward is going to make much difference :-)

    If the "latest" Java is 1.9 you might try uninstalling it and installing Java 1.8.

    If you have the patience you might see who else comes along with ideas and a better memory than mine, but most of them have day jobs and don't always post during the day.

    You might try generating a debug log.

    Start mafia, but don't log in.

    Help->Start Debug Log

    and then log in.

    Another question - Which windows are opened at startup as tabs and as windows?

    You can get that from General->Preferences Look & Feel->Main Interface
    You just vehemently agreed with me
    Originally Posted by Veracity View Post
    I agree with frono.
    Originally Posted by Veracity View Post

  5. #5
    Developer
    Join Date
    Apr 2010
    Posts
    4,525

    Default

    I have a very long pause at campground data, sometimes. Really isn't repeatable. I've put it down to which server I connect to, but it's possible something else is going on.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •