Results 1 to 8 of 8

Thread: Ignore autostops when teleportisis active

  1. #1
    Senior Member
    Join Date
    Feb 2010
    Posts
    905

    Default Ignore autostops when teleportisis active

    r18299. Since I'm spending a lot of turns auto-adventuring with teleportitis today I noticed the following:

    Auto-adventuring keeps stopping when I hit any of the shrines in the Hidden City. The choiceAdventure values for all the shrines are set to choose option 6 (skip).

    It also stopped on "I Just Wanna Fly".

    Any ideas?
    Last edited by Magus_Prime; 12-15-2017 at 12:26 PM.

  2. #2
    Developer
    Join Date
    Apr 2010
    Posts
    4,215

    Default

    That are autostops. Without them if you autoadventured at a shrine it would never stop trying and hitting KoL Servers 1000's of times.

    Not entirely sure why I Just Wanna Fly is, I guess making it easier to run that quest.

    Could make this a Feature to not autostop with Teleportisis ?

  3. #3
    Senior Member
    Join Date
    Feb 2010
    Posts
    905

    Default

    Works for me. If someone with the ability to do so would make the change it would be appreciated.

  4. #4
    Developer
    Join Date
    Apr 2010
    Posts
    4,215

    Default

    Try r18302 - untested.

  5. #5
    Senior Member
    Join Date
    Feb 2010
    Posts
    905

    Default

    Thank you! I'm out of turns for today but I'll try tomorrow.

    I just looked at the diff and noticed:

    Code:
    private static final AdventureResult TELEPORTISIS = EffectPool.get( EffectPool.TELEPORTITIS );
    and

    Code:
    KoLConstants.activeEffects.contains( EncounterManager.TELEPORTISIS ) )
    Is that a typo in the patch or is it actually misspelled in that way? Teleportitis != Teleportisis
    Last edited by Magus_Prime; 12-15-2017 at 02:22 PM.

  6. #6
    Developer
    Join Date
    Apr 2010
    Posts
    4,215

    Default

    Typo only, and won't affect behaviour. Fixed in r18303

  7. #7

    Default

    Without this update, setting any goal that you would never meet (a seal tooth maybe) would have avoided the autostops.

  8. #8
    Senior Member
    Join Date
    Feb 2010
    Posts
    905

    Default

    The change worked perfectly. I automated over three hundred turns, wearing a ring of teleportation, with no auto-stops.

    Thank you!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •