Results 1 to 6 of 6

Thread: Java version requirements.

  1. #1
    Developer Veracity's Avatar
    Join Date
    Mar 2006
    Location
    The Unseelie Court
    Posts
    11,112

    Default Java version requirements.

    I saw a post on G-D where somebody said that they were getting an "Unknown Method" (or some such Exception) on Arrays.copyOf.

    That was introduced in Java 6.

    I could swear we are using any number of other Java 6 features. (Note: the latest Java is Java 8).

    Java 7 requires (at least) OS X Lion - which is old.

    If you cannot run Java 6, I throw up my hands.

    Revision 18020 says we will use Java 6 language features and you must be running at least Java 6.
    Ph'nglui mglw'nafh Cthulhu
    R'lyeh wgah-nagl fhtagn.

  2. #2
    Developer Veracity's Avatar
    Join Date
    Mar 2006
    Location
    The Unseelie Court
    Posts
    11,112

    Default

    If somebody with posting privileges on G_D wants to say "upgrade your Java to at least SE 6 (which is obsolete)", please do so.
    Ph'nglui mglw'nafh Cthulhu
    R'lyeh wgah-nagl fhtagn.

  3. #3
    Developer
    Join Date
    Aug 2009
    Posts
    2,683

    Default

    Darzil did so. (reporting so the next person to come across this thread doesn't also have to read through the GD thread)

  4. #4
    Senior Member
    Join Date
    Jul 2012
    Posts
    155

    Default

    After this change, I'm getting a compile error on Linux. Specifically, "unmappable character for enoding UTF-8" in lib/apple/dts/samplecode/osxadapter/OSXAdapter.java (the copyright symbol in the comment). It appears that this file is in the SVN encoded as ISO-8859. Saving it as UTF-8 fixes this.

  5. #5
    Developer Veracity's Avatar
    Join Date
    Mar 2006
    Location
    The Unseelie Court
    Posts
    11,112

    Default

    Revision 18021 gets rid of the stupid non-ASCII character
    Ph'nglui mglw'nafh Cthulhu
    R'lyeh wgah-nagl fhtagn.

  6. #6

    Default

    verified. thanks for the quick fix!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •