Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19

Thread: Having trouble opening .jar or .exe Mafia on new computer

  1. #1

    Default Having trouble opening .jar or .exe Mafia on new computer

    I remembered having a similar problem previously, so I looked up to see my previous messages, hoping to mine some useful advice that I could re-use. No such luck, so maybe I'll be lucky enough to get some wizards to help me again?

    (From August 2014: http://kolmafia.us/showthread.php?16...ent-SVN-builds )

    My problems are very similar to the last time. I double click the .jar file, but no Mafia window opens, and nothing shows up in the task manager. Same thing for the .exe file.

    In the hopes of skipping ahead, I've already looked up the details that were requested last time:

    1. What is your OS?
    2. What is your version of javascript?
    Originally Posted by Bale View Post
    My OS is Windows 10.
    The version of Java is version 8, upgrade 111. I tried uninstalling it and re-installing it as well, which didn't produce any new results.

    I would suggest opening a command prompt window, navigating to the folder with mafia, and running "java -jar KoLmafia-{whatever}.jar", which will hopefully give some useful output. Try this with a version of mafia that works by double-clicking to check that this is all working properly, then try with a nonworking version and there will hopefully be some relevant output.
    Originally Posted by lostcalpolydude View Post
    If it's potentially useful, this is what that output gave me: http://i.imgur.com/ZB9gMUW.png

  2. #2

    Default

    Since I'm a lazy fuck i don't actually have a build and debug environment for Mafia, but looking at the code and testing a little bit seems to indicate that empty GLOBAL_prefs should never happen, and the code in main assumes that some basic preferences are initialized to nonzero things, and it crashes and burns upon stumbling over those empty preferences (here you can see that it fails basically because it tries to convert an empty string to a color). Since it's a directory on your desktop, I have no idea why something like this would fail, but try it in another folder you definitely have write access to, I guess?

  3. #3

    Default

    Somehow it's trying to set GUI values
    Code:
    DataUtilities.toColor( Preferences.getString( "innerTabColor" ) );
    without first setting default values for settings (so innerTabColor is an empty string). It isn't a surprise that toColor() fails there, but I can't reproduce this, so I don't know what to fix. Maybe it's newer versions of Java 8 that have an issue?

  4. #4

    Default

    Is there an earlier version of Java 8 that I could try it with?

  5. #5

    Default

    8u40 is the one that works for me. It looks like you can download that from http://www.oracle.com/technetwork/ja...8-2177648.html .

  6. #6
    Developer fronobulax's Avatar
    Join Date
    Feb 2009
    Location
    D.C. suburbs of Virginia, USA
    Posts
    3,666

    Default

    I'm running Java 1.8.0_111 64 bit with no problems so I don't think we should directly blame Java.

    I assume C:\Users\Dave!\EVERYBODY START\kolmafia is the directory that contains the Kolmafia.jar file. What other files and directories are in there? Can the user that is running actually read and write files there? Does deleting all the files and subdirectories there (except the mafia jar) and running again give different results? Would you consider creating C:\kolmafia, copying the jar file there and starting it there? Is there free space on the disk?

    I am old school and worry about things that do not need to be worried about but with both a space and an exclamation point in the path name it is possible something that is parsing to find or create files is not working in KoLmafia. Both of those were "no noes" in the days of 8.3 file names.
    You just vehemently agreed with me
    Originally Posted by Veracity View Post
    I agree with frono.
    Originally Posted by Veracity View Post
    There are 69 players more powerful than you.
    Originally Posted by Statistics Leaderboards

  7. #7

    Default

    I actually noticed something sort of similar on my new laptop yesterday:
    - I simply copied over the full KoLMafia folder from my old laptop, grabbed the newest nightly build, and tried to run it.
    Nothing.
    - Ok, maybe I didn't click it properly, lets try again.
    Still nothing.
    - Repeat once more.
    More nothing.
    - Ehm, I dunno what's up, lets (re)download the newest build and try again
    A big nothing.
    - Eh, maybe it's because I had a shortcut on my desktop? Lets make one and double click that.
    Once again nothing.
    - Ok, this is getting kinda strange, and I'm getting frustrated. Rapidly click the shortcut 5 or so times, with the task manager open to see if java is doing anything.
    And behold, mafia started, though, despite 'starting' it 8 or so times in this series (which took maybe 2 minutes, I was going through these motions kinda fast), I got exactly one login screen and only one instance was running.

    Edit: Since then, I've been able to start it multiple times without any issue, I even grabbed a new nightly build today without problems.
    Last edited by the dictator; 01-05-2017 at 01:46 PM. Reason: Typos, and a little more clarification

  8. #8
    Senior Member
    Join Date
    Feb 2010
    Posts
    834

    Default

    I simply copied over the full KoLMafia folder from my old laptop, grabbed the newest nightly build, and tried to run it.
    Originally Posted by the dictator View Post
    There may be file system permissions issues with Windows 10. What is the full path to where you copied the KoLMafia folder?

    Do other Java programs run properly on this computer?

  9. #9

    Default

    Did you even read to the end?

    But, in case it matters, both laptops are Windows 10, and on both sides, the path is "D:\Games\Kingdom of Loathing\KoLMafia"
    Last edited by the dictator; 01-05-2017 at 01:44 PM.

  10. #10
    Senior Member
    Join Date
    Feb 2010
    Posts
    834

    Default

    I did read to the end and the path does matter.

    Windows 10, in an attempt at protecting the user, puts barriers in place to prevent certain things when files are outside the user profile.

    Try copying the files a directory under your user profile and running from there. If that works then it's a file system permissions issue.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •