I think that might be a sign that you need to update Java. I remember something about older versions of java not handling https protocols properly. (Older meaning like half a year older than the most recent version.)

I don't remember though if it produced that exact error. Still, it cannot hurt to update java. Then let us know if you still have a problem.