PDA

View Full Version : refreshing icepenguin express



poopblade
01-08-2007, 11:47 PM
Hey guys...

I think a proper introduction is needed. I'm new to this forum. My IGN is poopblade. Yeah. :D

Anways, I was really hoping someone could help me with this problem. I need a script to refresh Icepenguin express. I found one made by nightmist. I set the wait() to 60 (for a 60 second delay time). It didn't work though...

Please help,
Thanks

Nightmist
01-08-2007, 11:56 PM
I made a Kmail parser? Eh?
Care to linky me to my old post?

Whats the point of scripting a Kmail parser anyway? I mean if your buff-botting you might aswell use the inbuilt function and since scripts lockdown mafia I don't see how it is useful?

poopblade
01-08-2007, 11:59 PM
http://kolmafia.us/index.php/topic,174.0.html

In-built function? There's one that refreshes every minute?

Nightmist
01-09-2007, 12:40 AM
http://kolmafia.us/index.php/topic,174.0.html

In that thread:


This script here runs fine on 6.4


Errr 6.4... right... anyway that script relied on the event manager to pick up the message and pop-up. I'm not even sure if the newer versions have that anymore so yeah... If it does then you need to find another way to trigger it to find a event and if it doesn't then your out of luck.

poopblade
01-09-2007, 01:15 AM
Lol, thanks.
The reason I ask this is because I'm not at my computer every second and when someone asks for a buff, I need to check my mail to buff them. (Version 10.0) I may be doing something wrong?

Nightmist
01-09-2007, 08:58 AM
Why don't you just use mafia's inbuilt buffbot functionality?

poopblade
01-09-2007, 09:15 PM
Is there one? Can you be more specific? There's a lot of functions the buffbot has but I don't think refreshing automatically is one of them. You have to check your mail to "buff automatically." Maybe we're talking about different versions; I'm using v10.0

efilnikufecin
01-09-2007, 10:06 PM
The buffbot does refresh kmail on it's own, and deletes the kmail after casting the buff, or refunding the meat if it cannot process the request. It would not be a bot if it did not. One of the most popular buffbots runs on kolmafia's buffbot interface. That buffbot is testudinata. on the "run buffbot" tab just click start after setting up all your settings, and it will begin refreshing kmail at a reasonable rate.

poopblade
01-09-2007, 10:31 PM
Ahh...yes, I understand that concept but it DOESN'T refresh. That's my problem. Can you please tell me how to set it up so it can refresh. (Yes I'm an idiot, I know)
I have it all set up, buff prices, mana restores, whitelists....

holatuwol
01-10-2007, 01:32 AM
You need mana restores in stock.

poopblade
01-11-2007, 02:05 AM
Ugh...That's the problem. I have everything set up. When I say everything, that means I relentlessly combed through the entire thing for an hour to make sure I wasn't missing anything. Does anyone else also have this problem or is it just my bad luck?

efilnikufecin
01-11-2007, 04:13 AM
OK digging a little deeper. I just tried to start the buffbot while not logged in to see what error message I would get.

Graphical cli window open.
no buff settings at all

this is the error message I got.

You need 1 more Rock and Roll Legend to continue.
Buffbot started. 1/10/07 10:03 PM:
Starting new session
Unable to continue processing buff messages. 1/10/07 10:03 PM:
Buffbot stopped.

Could you post the graphical cli output in here please? It should give a clear picture of what is going on in your case.

In my case the buffbot stopped because it was unable to process messages. The reason it was unable to process messages was because it was not logged in to kol, and would get re-directed by kol to the login page.

poopblade
01-13-2007, 03:24 AM
Ok..

With buffbot running:
10 days until Valentine's Day, 3 days until Mysticism. Validating login server... Redirected to www.kingdomofloathing.com... Redirected to www6.kingdomofloathing.com... Sending login request... Request completed. Initializing session for buffbucket... Refreshing session data... Synchronizing moon data... Request completed. Retrieving character data... Request completed. Refreshing closet... Retrieving equipment... Request completed. Retrieving familiar data... Request completed. Retrieving campground data... Request completed. Session data refreshed. You have nothing in storage. Buffbot started. 1/12/07 10:20 PM: Starting new session

Is this right?
When I run buffbot without logging in, I got
* Graphical cli window open.
* No buff setting at all (just like you)

I didn't get an error message.

Thanks for trying to help.

efilnikufecin
01-13-2007, 08:26 AM
odd, when I started the buffbot (while logged in) with no settings, it hung repeatedly checking messages with no delay between. It was pretty dang fast too. It was running less than 10 seconds, and here is the output:

Buffbot started.
1/13/07 2:08 AM: Starting new session
Retrieving mail from Inbox...
Your mailbox is empty.
1/13/07 2:08 AM: Message processing complete. Buffbot is sleeping.
1/13/07 2:08 AM: (10 mana restores remaining)
Retrieving mail from Inbox...
Your mailbox is empty.
1/13/07 2:08 AM: Message processing complete. Buffbot is sleeping.
1/13/07 2:08 AM: (10 mana restores remaining)
Retrieving mail from Inbox...
Your mailbox is empty.
1/13/07 2:08 AM: Message processing complete. Buffbot is sleeping.
1/13/07 2:08 AM: (10 mana restores remaining)
Retrieving mail from Inbox...
Your mailbox is empty.
1/13/07 2:08 AM: Message processing complete. Buffbot is sleeping.
1/13/07 2:08 AM: (10 mana restores remaining)
Retrieving mail from Inbox...
Your mailbox is empty.
1/13/07 2:08 AM: Message processing complete. Buffbot is sleeping.
1/13/07 2:08 AM: (10 mana restores remaining)
Retrieving mail from Inbox...
Your mailbox is empty.
1/13/07 2:08 AM: Message processing complete. Buffbot is sleeping.
1/13/07 2:08 AM: (10 mana restores remaining)
Retrieving mail from Inbox...
Your mailbox is empty.
1/13/07 2:08 AM: Message processing complete. Buffbot is sleeping.
1/13/07 2:08 AM: (10 mana restores remaining)
Retrieving mail from Inbox...
Your mailbox is empty.
1/13/07 2:08 AM: Message processing complete. Buffbot is sleeping.
1/13/07 2:08 AM: (10 mana restores remaining)
Retrieving mail from Inbox...
Your mailbox is empty.
1/13/07 2:08 AM: Message processing complete. Buffbot is sleeping.
1/13/07 2:08 AM: (10 mana restores remaining)
Retrieving mail from Inbox...
Your mailbox is empty.
1/13/07 2:08 AM: Message processing complete. Buffbot is sleeping.
1/13/07 2:08 AM: (10 mana restores remaining)
Retrieving mail from Inbox...
Your mailbox is empty.
1/13/07 2:08 AM: Message processing complete. Buffbot is sleeping.
1/13/07 2:08 AM: (10 mana restores remaining)
Retrieving mail from Inbox...
Your mailbox is empty.
1/13/07 2:08 AM: Message processing complete. Buffbot is sleeping.
1/13/07 2:08 AM: (10 mana restores remaining)
1/13/07 2:08 AM: Buffbot stopped.

you did notice this message from Holatuwol didn't you?



You need mana restores in stock.


Before I bought 10 Magical mystery juice, I got similar results to what you are describing. Also on the main settings page in the buffbot manager be sure you have the proper mana restorer selected to use.

poopblade
01-14-2007, 02:03 AM
Wow, I can't believe the solution was that simple!
Yes, I did read holatuwol's message and I thought I had 100 soda waters but I didn't realize I used all of it when I was testing the buffbot.

Thank you. :D

P.S. How come it doesn't work when I set it to rest at campground?

efilnikufecin
01-14-2007, 03:33 AM
Wow, I can't believe the solution was that simple!
Yes, I did read holatuwol's message and I thought I had 100 soda waters but I didn't realize I used all of it when I was testing the buffbot.

Thank you. :D


100 soda water to a buffbot is like a drop of water in a bucket.



P.S. How come it doesn't work when I set it to rest at campground?


Maybe something is broken?